Anki 2.1.54 Release Candidate

Hi all,

A 2.1.54 release candidate is now available:

If no issues crop up, the plan is to release it as stable in approximately a week.


Thanks! On macos, the browse window now only sorts by the due date, and I’m no longer able to click the column headings to change sort column/order, is it a qt 6.3.1 issue? (version anki-2.1.54+rc1_595c9273-mac-apple-qt6)

Looks like a Qt bug. I’ll fix this in the next build; the following in the debug console should fix it for now. You’ll need to reconfigure your columns afterwards.


(edit: I had the wrong keys; I’ve edited the post to correct it)


Thanks! Just removing the two keys above does not solve the issue on my end, after some digging around looks like I also need to do the Qt6 keys


Thank you for the update.

Bug:Columns cannot be moved and clicked when the browse window is in card state.(Version ⁨2.1.54 (595c9273)⁩
Python 3.9.7 Qt 6.3.1 PyQt 6.3.1)

The old file importer can map all fields automatically in sequence.
In this new importer, I need to keep informing which field each one references.

@Jason30 please see my reply above your post

@cjdduarte I can’t seem to reproduce this - when I import the import screen each of the fields in the notetype is mapped automatically in order. What does the preview show above?

@dae Here’s an example

Import the attached (Model and file) file in the old importer and in the new importer:
I also attach the model: MODEL AND FILE

Old Importer:

Clear the data and re-import in the new importer.

New Importer:

1 Like

Version ⁨2.1.54 (595c9273)⁩
Python 3.9.7 Qt 6.3.1 PyQt 6.3.1
Windows 10

If I create a new Field Description, any note that already had such field as non-empty will display both the inline description and the field content, at the same time.
This can be fixed by making any edit to the field.


The new “Browse” window has a number of disimprovements over the old, many of which can be seen in this screenshot (using Ubuntu 22.04):

  • The columns seem to have a rather large minimum width, i.e. cannot be resized smaller to efficiently utilize screen real estate so as to be able to see more information at a glance (especially wasteful for “Reviews” and “Lapses” columns)
  • The column header is right-aligned, which looks odd, especially for the first column (see screenshot) – they used to be centered
  • The contents of number cells have been left-aligned (used to be centered), which also looks odd, especially for fields such as “Reviews” and “Lapses” (but also the date fields)
  • The first field (Sort Field) seems to use another (smaller) font than the other columns, making the text appear to ‘float’ at the top of its cell (instead of being in the middle) – is this adjustable somewhere?

Screenshot for illustration:


The sort field column uses the font configured for that field. That’s not new. But regardless, it should not be aligned at the top. This is probably related to the broken center alignment you report and another Qt issue.
The other issues, as the one reported by @Jason30, must be fixed as described above.

1 Like

Thanks for the report, @hkr fixed this issue today:


Your file does not follow the CSV standard properly. Quotation marks must wrap an entire field, which is not the case due to the leading spaces. But nonetheless, automatic mapping works fine for me when I import that file. Can you reproduce the issues with a properly formatted file?


I changed as you suggested and it worked.
However, only the TAG field is not being mapped automatically.

"42e9a7d1eadde27945ed9791d4818731","A1","B, B","C, C","D","EEE,EEE","F","G","H","I","test::tagA1"
"42e9a7d1eadde27945ed9791d4818732","A2","B, B","C, C","D","EEE, EEE","F","G","H","I","test::tagA2"
"42e9a7d1eadde27945ed9791d4818733","A3","B, B","C, C","D","EEE, EEE","F","G","H","I","test::tagA3"
"42e9a7d1eadde27945ed9791d4818734","A4","B, B","C, C","D","EEE, EEE","F","G","H","I","test::tagA4"

@Rumo I confirmed that only the tag is not mapped.
I changed my csv generator program with the code below and it works. Minus the tag field.

csv.DictWriter(csvfile_PR,  fieldnames=fieldnames_PR1,  delimiter=',', quoting=csv.QUOTE_ALL, quotechar='\"')

Another situation that I found in the tests: The old version of the importer saves the presets of the note type and the parameters selected by deck. After I import for the first time, it saves the presets

In this new version I have to configure all the parameters again with each import. He doesn’t save.

Release candidate 2 is now available:

It introduces a bug with adding that will need to be fixed in rc3: Selected field is not clearel


rc2 should fix the issue where the mapping was not recalculated after changing the delimiter. While we could potentially remember the selected notetype and deck in the future, a better way to handle this on your end is to specify the desired settings inside your text file, especially since you appear to be generating the text file with a script.


@dae Your suggestion works. As I use a script to create my cards, it solved by inserting this here at the beginning of the file:

#notetype:QC - PR1 (PDF) com ADMONITION
#tags column:16

But I didn’t find a key for “Existing notes”. I always need to change manually.
Could it be created or is it not in the tutorial?


With that last key, the problem is solved. :grinning:

Release candidate 3 is now available: Changes in 2.1.54 - Anki Betas

@cjdduarte AFAIK, we do not currently provide an option for that in the file.

1 Like

Thanks for your quick update work!