Upgrade doesn't work // free disk space is written full

I tried to upgrade anki to version 2.1.44 under linux.

Two problems occurred. Last problem is more problematic.

A) Update did not work

It was not successfull. Anki did not start in that way, that the normal window appeared. Also selecting an backup as suggested did not work. Maybe it is caused by the addons installed. The report is attached at the end of the post.

B) Anki writes free disk space full

So I tried a second time to update.

Anki seems to copy the content of the home folder to /usr/local/share/anki. I saw in the terminal after sudo install.sh that all those files appeared by name. So I closed the terminal. Later I saw, that there is space left on the file system (0 byte). I think it is caused by anki. Anki copied approximately 50 gigabyte to that location (/usr/local/share/anki).

C) Report

An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.
If the issue only occurs when add-ons are enabled, please use the Tools>Add-ons menu item to disable some add-ons and restart Anki, repeat until you discover the add-on that is causing the problem.
When you’ve discovered the add-on that is causing the problem, please report the issue on the add-ons section of our support site.
Debug info:
Anki 2.1.15 (442df9d6) Python 3.8.5 Qt 5.12.8 PyQt 5.14.1
Platform: Linux
Flags: frz=False ao=True sv=?
Add-ons possibly involved: Image Occlusion Enhanced for Anki 21 alpha

Caught exception:
File “/usr/share/anki/aqt/utils.py”, line 279, in accept
File “/usr/share/anki/aqt/main.py”, line 235, in doOpen
File “/usr/share/anki/aqt/main.py”, line 254, in _openBackup
File “/usr/share/anki/aqt/main.py”, line 187, in onOpenProfile
File “/usr/share/anki/aqt/main.py”, line 277, in loadProfile
File “/usr/share/anki/anki/hooks.py”, line 29, in runHook
File “/home/userxy/.local/share/Anki2/addons21/1374772155/main.py”, line 203, in onProfileLoaded
File “/home/userxy/.local/share/Anki2/addons21/1374772155/config.py”, line 78, in getSyncedConfig
if ‘imgocc’ not in mw.col.conf:
<class ‘AttributeError’>: ‘NoneType’ object has no attribute ‘conf’

The error you’re pasting is from 2.1.15, so it sounds like you had an older version of Anki lying around.

The instructions say to run ‘sudo ./install.sh’. It sounds to me like you ran the script from your home folder instead. I will add a check for this.

Thank you for your fast reply.

D) Description of installation

I dragged and dropped the unpacked installation folder to the terminal. The installation folder was placed in the /home/downloads folder. Then I ran ‘sudo install.sh’ instead of ‘sudo ./install.sh’.

E) Used version

Which version of anki was involved i can’t say certainly. I had once installed version 2.1.15 as normal and flathub package. I thought i used the linux package from the website for more than a half year. The version I used had the old UI. I also found a version 2.1.35 folder direct in my /home folder.

After looking into the version history on github I think update notifications should have appeared more often, if I used the package from the website. I can not remember to have installed an update this year.

Most people don’t want to be prompted to update every month, so the update notifications are not sent on every update.