I’m going to port libanaki’s unit test to AnkiDroid (at least, that would be my goal)
Would you be open to me renaming some variable in anki. E.g.
d to represents a collection is not consistent with main code, which uses
col. I know “collection” used to be called “deck”, but since there are “decks” which represents something else, it makes things confusing.
Similarly, “fact” have been renamed to “note” if I understand correctly, so using
n instead of
f would be helpful.
I’m trying to automate as much as possible the porting of tests, so if you’d accept such a correction, I prefer to do it before porting the code to Android.