No "enable second filter" option

I am trying to make a custom filtered deck for cards due today and for cards that are overdue, and to do this I was planning on entering in " Deck:“Deck 1” is:due prop:due>-1 " and then adding a second filter for another deck so that cards from both decks would be filtered into the same deck. However, I do not have the “enable second filter option” So I’m not sure how to go about this.

You need to enable the experimental scheduler from Preferences > Scheduling for this option to appear.