Invalid input: not at top of queue, can't rate card 'good'

An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.
If the issue only occurs when add-ons are enabled, please use the Tools > Add-ons menu item to disable some add-ons and restart Anki, repeating until you discover the add-on that is causing the problem.
When you’ve discovered the add-on that is causing the problem, please report the issue on the add-on support site.
Debug info:
Anki 2.1.44 (b2b3275f) Python 3.8.6 Qt 5.14.2 PyQt 5.14.2
Platform: Mac 10.14.6
Flags: frz=True ao=True sv=2
Add-ons, last update check: 2021-08-21 20:48:56

Caught exception:
Traceback (most recent call last):
File “aqt/”, line 526, in handler
File “aqt/”, line 337, in _onAnswerButton
File “aqt/”, line 270, in _answerCard
File “anki/”, line 126, in answerCard
File “anki/”, line 149, in _answerCard
File “anki/_backend/”, line 222, in answer_card
File “anki/_backend/”, line 106, in _run_command
anki.errors.InvalidInput: Invalid input: ⁨not at top of queue⁩

This error occurs when I rate a card ‘good’. This problem started after I updated to the AnKing V10 deck. This same error happens on different cards that I rate ‘good’. Is it because I rescheduled these cards? Tried checking media and database to see if that would make a difference but it hasn’t. Also a specific add-on is not specified in the error so I’m not sure if it’s an add-on that is doing this. I’ll disable the progress bar add-on I manually installed from glutanimate’s github for 2.1.44 and see what happens for now.

Please see When problems occur - Frequently Asked Questions

Hello, I have the same issue. Please update if you were able to resolve. Thanks!

Personally for me, the problem was fixed when I removed the add-on “Show total review count in main screen.” I also was using a forked version of Review Heatmap instead of the official one from glutanimate on GitHub so that may have also fixed it as well.

1 Like

@zenitsulightning I recommend you update to the latest Anki version. You have the v3 scheduler enabled, and it was only partly complete in 2.1.44. If you’d like to remain on 2.1.44, please disable it with the latest version, then downgrade again.

@mashed dae responded! I also did this!!! It was probably not add-on related then and instead due to v3 scheduler enabling. I disabled the v3 in 2.1.46, downgraded back to 2.1.44, and it started working again!!!

Thanks so much for responding, will do! :+1::+1: