"Due" should be renamed (somewhere) for clarity

“Due” label in the interface is confusing because:

  • it seems to be too general or too many counters are called “Due”
  • it labels different and not equal numbers
  • it seems to be called “To review” in the manual but “Due” on the main screen

For example, for one of my decks I have:

Anki main screen
Learn 105
Due 68

Browser: Today: Due (prop:due=0)
145 cards (both Learn and Review according to the cards’ info)

Browser: is:due
173 cards (matches the sum of Learn and Due - recursion)

Browser: is:due is:review
82 cards

Browser is:due is:learn
105 cards (this one matches Learn but contradicts the separation of Learn and Due)

So, basically, those numbers don’t match over the UI, which is very confusing because eventually there is nothing meaningful behind the word ‘due’.

(For some reason uploading PNG screenshot fails)

And the main reason I found it is that it’s really hard to translate meaningfully.

The ‘deck overview screen’ is not the screen with the deck tree, and the manual page you linked is agreeing with the actual GUI there. But as for the deck tree screen, I agree that the third card column should be labeled ‘Review’.
The search syntax is also correctly documented, and I don’t see a problem with how it uses the word ‘due’. In short why your numbers don’t add up: prop:due=0 is not the same as is:due, and is:review and is:learn are not mutually exclusive. See the link for more information.

prop:due=0 is not the same as is:due

And that’s the problem with the naming: different things should be called differently.

Anyway, the main problem is in the UI (which is quick to fix), not the query language.

I suggest:

Due on the main screen → Review
New, Learning, To review on the deck overview screen → match the main screen (they’re the same stats, right?)
Browser: Today: Due → Due next day cutoff

They’re not different things. The first one is only more powerful syntax, which in this case allows you to ask for “cards that have become due today”, whereas the second one can only mean “cards that have become due”. The latter can also be written as prop:due<=0.

1 Like

prop:due=0 is not the same as is:due

Please choose one.

Due was originally chosen over Review for the deck list screen to try to keep the width of that column down. Learning cards are also due, and we now show them separately, so it’s potentially more confusing than it was in the past, and perhaps we should change it.


In both prop:due=0 and is:due, “due” is carrying the same meaning, which to my understanding is the point of this thread. But obviously, the two searches are not the same, because they contain other stuff as well.
E.g., strawberries and raspberries are aptly named, because they are both berries. But that doesn’t mean they are the same. :slightly_smiling_face:


Maybe full labels are not really needed on the main screen, just color-coded N, L and R may be used, and on mouse-over the corresponding tooltips “New”, etc. will appear.

In the left sidebar these due varieties may be called ‘Total due’, ‘Daily due’, ‘Today’s due’ or anything else.

Which becomes even funnier that none of them is a berry in the strict botanical sense.

I always found that a bit confusing. Made me question my English skills.

Initials will be different depending on the UI language, so it might cause even more confusion. I experimented with color coded icons for a main window rework:


Hovering shows the attribute. The increasing “signal strength” should convey the progression from “new” to “review”.


I tried changing it; it looks a bit cramped now.

The signal strength icons are nice and compact, and make sense when you explain them. They may not be obvious to new users, but if we have a tooltip that will help.

1 Like



It’s a reasonable solution, though I imagine some people may prefer the status quo. With @kleinerpirat’s work in progress, perhaps we might be better off leaving it as-is for now?