Bug. Strange behavior of the links in card templay - deja vu

Some links are clickable, some not. On screenshots the link to reverso.com Synonyms clickable, link to Google.com not. ???


AnkiDroid Version = 2.18alpha6 (d80b76744dcceab3d82fb30e028e76229c7fe03f)
Backend Version = 0.1.34-anki23.12.1 (23.12.1 1a1d4d5419c6b57ef3baf99c9d2d9cf85d36ae0a)
Android Version = 13 (SDK 33)
ProductFlavor = play
Manufacturer = LENOVO
Model = TB370FU
Hardware = mt8791
Webview User Agent = null
ACRA UUID = 50bbf983-dc20-4532-a996-c5b6c776dece
FSRS Enabled = false
Crash Reports Enabled = true

1 Like

Is it possible that it is actually a “clickable” link, but just not formatted the usual way (blue and underlined)?

Can you post the code for the card – Front, Back, and Styling? It’s easier to work with than a screenshot. From that Card tempate screen, you can get all of those by clicking 3-dots menu > Copy as Markdown.

1 Like

“Google” is not clickable (doesn’t open google in browser). “Synonyms” is clickable (opens Reverso.com in default browser). Have tried on 2 devices (tablets) with A12 and A13 on.

FRONT

<div align="center" style='font-family: Arial; font-size: 24px;'>
<a href="https://google.com/">Google</a>
</div>
<br>
`<hr id=answer>`
<div align="center" style='font-family: Arial; font-size: 16px;'>
<a href="https://synonyms.reverso.net/synonym/pt/">Synonyms</a></div>

{{Portuguese}}
{{Audio}}

{{#Tags}}
<br>
{{hint:Tags}}
{{/Tags}}

BACK
{{FrontSide}}
<hr id=answer>
{{English}}

{{Audio}}
{{#Tags}}
<br>
{{Tags}}
{{/Tags}}

CSS
.card {
font-family: arial;
font-size: 20px;
text-align: center;
color: black;
background-color: white;
}
.card1 { background-color: #FFFFFF; }
.card2 { background-color: #FFFFFF; }

I’m not sure what’s going on with this for you, because I pasted that code into templates on Droid and Desktop, and both immediately worked as links.

Have you tried it on a non-alpha, released version (like 2.17.6)? Have you tried it in Desktop?

I do notice 1 thing (but I hesitate to mention it, because the links worked for me without fixing it). I don’t claim to be an ace at HTML, but in your style= attributes, aren’t those usually double quotes, instead of single quotes?

I believe the original URL that doesn’t work I copied (copy/paste) directly from address line of the Opera or Chrome browser (don’t remember). It is the first line in<div>block.
The second line I have just copied a working link in the bottom of the same card and than changed manually the URL.
The third line is a copy of the first one just to confirm mystery.
Before I reinstalled AnkiDroid on 3 devises (2 tablets an 1 smartphone, A13, A12, A12).
Icon link works perfectly despite I copied it directly from Play.
Maybe some hidden codes copied together with URL but it’s clear that this mystery should be processed as an issue and at least explained somewhere in help documentation


I didn’t question the accuracy of your urls. But I asked other questions you didn’t answer, so I don’t know how to help you more. [I might not be able to even *with* those answers, but at least you’ll have a shot.]

Usually something can only be processed as an issue if it is reproducible, and so far, this isn’t. If you want to post that code here too (text, not screenshots), maybe someone will be able to reproduce it.