Anki 2.1.66 Beta

That looks like a video driver issue. You may have more luck switching to software more, or the qt5 build.
https://docs.ankiweb.net/platform/windows/display-issues.html#qt6

1 Like

Windows 10
Anki Version ⁨2.1.66 (46915605)⁩
Python 3.9.15 Qt 6.5.2 PyQt 6.5.2

In light mode, the tooltips/titles are a bit difficult to read

image

Compare with 2.1.65
image

Yes, I followed your guide and solved the problem. Thank you very much~

1 Like

There is a lag when moving the cursor in the deck screen and I have disabled all plugins. Here a less than 10 seconds video demo 芦笋录屏官网 - 视频讲解,用芦笋

Anki 2.1.66 (46915605) Python 3.9.15 Qt 6.5.2 PyQt 6.5.2
Platform: Windows-10-10.0.22621
Flags: frz=True ao=False sv=3
Add-ons, last update check: 2023-08-10 18:19:52


===Add-ons (active)===
(add-on provided name [Add-on folder, installed at, version, is config changed])
Edit Field During Review Cloze ['385888438', 2023-07-31T21:21, '6.15', mod]
FSRS4Anki Helper ['759844606', 2023-08-01T17:06, 'None', '']
Quick tagging 21 ['304770511', 2020-02-11T14:17, 'None', '']

===IDs of active AnkiWeb add-ons===
304770511 385888438 759844606

===Add-ons (inactive)===
(add-on provided name [Add-on folder, installed at, version, is config changed])

It’s a video driver issue. You can turn on minimalist mode/reduce motion to reduce the animations.

1 Like

What is the estimated time until the 2.1.66 release? Asking because we have been blocked by this issue for quite some time now and can’t release a new version of one of our add-ons that is going to rely on the affected functionality.

@glutanimate is still working on some I/O changes I believe. Once they’re done, I can get a new beta out, and hopefully a release out a few weeks later.

3 Likes

Apparently those changes are going to take a bit more time, so I/O support has been pushed back to the following release. I’ve just uploaded a 2.1.66 release candidate, and the plan is to release it as stable within a week, if no issues are found.

2 Likes

I have an external screen set up above my laptop’s built-in screen. The laptop is running Windows 11 Pro build 22621.2215. In both the first beta and the release candidate (Qt6), menus open on the built-in screen, even when Anki is partially or entirely on the external screen. This didn’t happen with 2.1.65.

With Anki on the main screen.
image

With Anki on the external screen. The greenish bar is the taskbar at the bottom of the main screen. The menu opens right at the top of the built-in screen below it.
image

Let me know how I can provide more information, if required, to help identify the issue.

2.1.66 has now been released as stable, without any changes since rc1.

@temlivurki this unfortunately sounds like a regression in the toolkit. Does the same thing happen when you put it in software mode? Display Issues - Anki Manual. I’ve logged the issue on Strange menu behaviour on multi-window setup with Qt 6.5/Windows · Issue #2622 · ankitects/anki · GitHub

3 Likes

3 posts were split to a new topic: Menu pops up on wrong display

@dae
website homepage still shows Anki 2.1.65

1 Like

This new version of Anki is trying to install on my username and not on program files. It has been changed?

image

This changed in 2.1.64: Changes in 2.1.60 to 69 - Changes

2 Likes

Hi.
I am checking 2.1.66 Beta with Mac M1 Qt6 version.
When I selece multiple card on browser with shift+click or cmd+click, the window suddenly shut down. I tried several times and got same results.
Below is an excerpt of error report.


Translated Report (Full Report Below)

Process: anki [27376]
Path: /Applications/Anki.app/Contents/MacOS/anki
Identifier: net.ankiweb.dtop
Version: 2.1.66 (???)
Code Type: ARM-64 (Native)
Parent Process: launchd [1]
User ID: 501

Date/Time: 2023-08-28 16:54:16.6935 +0900
OS Version: macOS 13.4.1 (22F770820d)
Report Version: 12
Anonymous UUID: E250B4C0-6C11-3574-0DD7-C0C8B27C1F2B

Sleep/Wake UUID: CB41C42C-A4CD-4BBE-8072-F57B57D41D67

Time Awake Since Boot: 260000 seconds
Time Since Wake: 488 seconds

System Integrity Protection: enabled

Crashed Thread: 0 CrBrowserMain Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000008
Exception Codes: 0x0000000000000001, 0x0000000000000008

Termination Reason: Namespace SIGNAL, Code 11 Segmentation fault: 11
Terminating Process: exc handler [27376]

VM Region Info: 0x8 is not in any region. Bytes before following region: 105553518919672
REGION TYPE START - END [ VSIZE] PRT/MAX SHRMOD REGION DETAIL
UNUSED SPACE AT START
—>
MALLOC_NANO (reserved) 600018000000-600020000000 [128.0M] rw-/rwx SM=NUL …(unallocated)

Thread 0 Crashed:: CrBrowserMain Dispatch queue: com.apple.main-thread
0 QtWidgets 0x10d9820a0 QWidget::raise() + 52
1 QtWidgets 0x10da73344 0x10d92c000 + 1340228
2 QtWidgets 0x10daa9080 0x10d92c000 + 1560704
3 QtWidgets 0x10daa8998 0x10d92c000 + 1558936
4 QtWidgets 0x10d9664a8 QLayoutPrivate::doResize() + 224
5 QtWidgets 0x10d966af0 QLayout::activate() + 1224

Does the “reset window sizes” option in the preferences help?

On 2.1.66, the toolbar for both HyperTTS and Language Tools addons stopped working with the following output in the console:

JS warning /_anki/js/editor.js:437 No version information available for component [tex]/noerrors
JS warning /_anki/js/editor.js:437 No version information available for component [tex]/mathtools
JS warning /_anki/js/editor.js:437 No version information available for component [tex]/mhchem
JS error /_anki/js/editor.js:530 Uncaught Error: Cannot require "svelte/internal" at runtime.
JS error /_anki/js/editor.js:530 Uncaught Error: Cannot require "svelte/internal" at runtime.
configureEditorHyperTTS(["New Preset"], 'New Preset', false)
JS error /_anki/legacyPageData?id=140607728117648:1 Uncaught ReferenceError: configureEditorHyperTTS is not defined
JS error /_anki/legacyPageData?id=140607728117648:1 Uncaught ReferenceError: setLanguageToolsEditorSettings is not defined

Here is the code used to build editor components for HyperTTS: https://github.com/Language-Tools/anki-hyper-tts/tree/main/web

I looked at the changelog but couldn’t find which change exactly might have caused this, also I see that this repository is unchanged: GitHub - hgiesel/anki_new_format_pack, if there was a change in the Svelte API, I would have expected “anki_new_format_pack” to reflect this.

Anyone else with svelte editor extensions experienced the issue ? Is it possible I need to upgrade the svelte version to get things running again on HyperTTS ?

I’m guessing this was caused by the upgrade to Svelte 4. I’ve logged the issue on Something (probably Svelte 4 upgrade) has broken exported components · Issue #2629 · ankitects/anki · GitHub. hgiesel has moved on, so we unfortunately can’t defer to him on this.

I kind of share the sentiment, I’m much more comfortable with the Python API that Anki has maintained over the years. I love the idea of being able to interact with the editor, but i’ll probably look for a more robust approach.

Just curious what were the main motivations for moving most of the editor to Svelte/Typescript, is it because displaying HTML content (which the editor will of course contain) is smoother that way ?

Thanks for your reply. After doing the “Reset window size”, the simptom disappeared.