Anki 2.1.50 Beta 1 & 2

I’m having the same problem. Which package did you use?

1 Like

from the previous 2.1.50 testing (New toolkit and packaging test (round 2): Index of /downloads/beta/pkg-test-2/

thanks a lot, fixed

4 posts were merged into an existing topic: Add-on issues with Anki 2.1.50 Beta

Bug report! (Linux mint 20.2 XFCE, kernel: 5.4)

  1. (Qt5 & Qt6) Inside “preference”: “Theme: follow system” don’t recognize system night theme
  2. (Qt5 & Qt6) Old status screen breaks (Shift + “Stats”)

Note: is not 100% of the time that the stats breaks

  File "aqt.webview", line 41, in cmd
  File "aqt.webview", line 148, in _onCmd
  File "aqt.webview", line 600, in _onBridgeCmd
  File "aqt.toolbar", line 168, in _linkHandler
  File "aqt.toolbar", line 189, in _statsLinkHandler
  File "aqt.main", line 1148, in onStats
  File "aqt", line 116, in open
  File "aqt.stats", line 144, in __init__
  File "aqt.stats", line 190, in refresh
  File "anki.stats", line 113, in report
  File "anki.stats", line 145, in todayStats
  File "anki.stats", line 1090, in _revlogLimit
  File "anki.decks", line 411, in active
  File "anki.scheduler.v3", line 237, in active_decks
  File "anki.dbproxy", line 71, in list
  File "anki.dbproxy", line 60, in _query
  File "anki._backend", line 79, in db_query
  File "anki._backend", line 102, in _db_command
TypeError: a bytes-like object is required, not 'list'

Qt warning: QXcbConnection: XCB error: 3 (BadWindow), sequence: 1471, resource id: 9876633, major code: 40 (TranslateCoords), minor code: 0

about the Qt warning, also getting those when pressing “x close” on “check media” or when “build” in “options for filtered decks”

Easiest fix until the next beta: after running as normal, run the following:

sudo chmod -R a+r /usr/local/share/anki

A fix will be in the next beta thanks to @hkr

The detection depends on your GTK theme name having -dark in it.

Thanks, should be fixed.

Probably a Qt bug, and can probably be ignored if it’s not causing any problems.

1 Like

A post was merged into an existing topic: Add-on issues with Anki 2.1.50 Beta

Version ⁨2.1.50 (43c41d76)⁩
Python 3.9.7 Qt 6.2.0 PyQt 6.2.0
Macbook Air (M1, 2020)
MacOS 12.0.1 (Monterey)

Deleted inline MathJax code reappears when focusing onto the next field

Expected behavior:
The mathjax snippet shouldn’t reappear if I delete it then focus the next field

Steps to reproduce:

  1. Type the following into the first field:

I like mathjax

(where mathjax is an inline mathjax format)

  1. Click on the mathjax snippet and click the delete button
  2. Click (or Tab) into the next field

After you delete the snippet, hit backspace once, then the snippet won’t reappear.

I’m not sure if this is actually a bug or expected behavior for HTML

I’ve yet another problem. After running as normal and running the above command, I try running anki, and it gives me this:

pinnerup@ergi:~/Downloads/anki/anki-2.1.50-linux-qt6$ anki
Anki starting...
Initial setup...
Running with temporary Qt5 compatibility shims.
Run with DISABLE_QT5_COMPAT=1 to confirm compatibility with Qt6.
Preparing to run...
xkbcommon: ERROR: Couldn't process include statement for 'dk(polytonic)'
xkbcommon: ERROR: Abandoning symbols file "(unnamed)"
xkbcommon: ERROR: Failed to compile xkb_symbols
xkbcommon: ERROR: Failed to compile keymap
[5102:5141:1205/] Keymap file failed to load: dk-polytonic
Trace/breakpoint trap (core dumped)

EDIT: The error only appears with the Qt6 version. The Qt5 version runs as expected.

Something about your keyboard setup seems to be tripping Qt6 up. I recommend you fiddle with your keyboard config to determine the line that triggers it, then report the issue on

The new Alt + I shortcut is not working for “Previous Card Info” here. I’ve tried with different kb layouts, but none of them seems to work. No add-ons / other programs are being used.

As a purely cosmetic issue, the new icons are considerably bigger than those in the previous version, and, IMO, seems too large compared to other on screen elements. Same can be said of tag icons:


As a suggestion, the new full-screen mode (F11) is great, but hard to discover. Would you consider adding that option to the menus (maybe under “Edit” or “Tools”?

W10, QT6, no add-ons.


The shortcut was changed to Ctrl+Alt+i to fix issues mentioned here: Option+I shortcut conflicts with language input


Ah, OK, Ctrl+Alt+i works, but the “More” menus shows this:


Thanks for the report. There’s a few issues with Mathjax still, and I’ll include this in the list. I’ll hopefully get them out before the next beta.

1 Like

This was likely caused by the toolkit update, since we haven’t changed the scaling factor ourselves. I made a PR.

It should be better on the next Beta release :slight_smile:


I like the idea, but only a few windows have a menubar. If we only added an entry to the main window, users might infer that other windows couldn’t be opened in fullscreen.
I would rather rely on inclined users trying their OS fullscreen shortcut and keep things simple.

1 Like

Loading images is sometimes much slower than usual. I’ll try to find some pattern and elaborate with more detail if I can.

Also, just after trying a card with mp3 embedded, I’ve received the “mpv not installed” message. I’ve never had that problem before, and simply restarting the program solved the problem. I’ve tried to replicate the problem, with no luck, but will keep an eye.

The layout is already flipped for RTL languages as far as I know, but aligning the contents of fields to the right automatically may not be desirable as RTL users don’t necessarily write all their cards in RTL languages. There is already an option to configure RTL direction under the Fields button.

about the recent conversion from camelCase to PEP8 compliant function and variable names (lowercase separated by underscores): I suggest to keep one exception in the long run, i.e. pointVersion besides point_version.

Otherwise - at least as far as I see - all add-ons that have one code base for all supported anki versions would have to work with try-except statements to find the proper point version which should be a lot of work among the many add-ons compared to just one line in anki itself?

Previously the window was aligned to the right but now the edit bar and field title and tags are aligned to the left unlike before.
And it has nothing to do with the content of the field.
By the way, the content of the field is aligned to the left in many cases even though in the actual back it is aligned to the right.
I’m trying to upload a picture but an error keeps popping up.

1 Like